TaxSlayer

Software Limitations

Does not support:

Support/Help Desk

http://www.taxslayer.com/helpCenter.aspx

Computer Requirements

Windows 98, 2000, Me, XP, or NT 4.0; with Microsoft Internet Explorer (5.5 and higher or America Online (4.0 or higher), or Macintosh OS X, using the latest versions of Internet Explorer. Printer requires Adobe Acrobat Reader, available via free download. Modem running at 28,800 bps or faster.